Failed uploading: uploading error: exit status 1

Hardware geleverd door Arduino
Berichten: 2
Geregistreerd: 27 Jan 2023, 21:43

Failed uploading: uploading error: exit status 1

Berichtdoor Laurens » 30 Jan 2023, 23:12

Hallo

Na eindeloze pogingen om een sketch (modelspoorprogramma Ex-Commandstation) op een nieuwe Mega2560 te krijgen heb ik een andere aangeschaft.
Nu een Elegoo gekozen. En de upload ging vlekkeloos.

Wat doe ik nu aan/met de andere Mega2560; waar ik zelfs het programmaatje "blink" niet op geïnstalleerd krijg (behalve weggooien :) )
Hoe krijg ik dat ding aan de praat?

Suggesties zijn van harte welkom

Met vriendelijke groet,

Laurens

Advertisement

Berichten: 4059
Geregistreerd: 16 Okt 2013, 14:31
Woonplaats: s hertogenbosch

Re: Failed uploading: uploading error: exit status 1

Berichtdoor shooter » 02 Feb 2023, 10:12

wat voor een USB chip zit er op beide denk aan CH340 dat beteknt een aparte usb op je PC zetten en blink staat er standaard al op dus je moet dan wel even de tijden veranderen in 500 of zo
de vuilnisbak staat in mijn werkplaats en daar kijk ik wat teveel in en haal er van alles uit. ofwel kijken kan altijd ook naar jouw MEGA hoor.
paul deelen
shooter@home.nl

Berichten: 180
Geregistreerd: 26 Aug 2015, 11:57

Re: Failed uploading: uploading error: exit status 1

Berichtdoor Frits1956 » 02 Feb 2023, 19:48

De suggestie van Shooter is niet eens zo gek. Als je in de buurt van den Bosch woont wil hij hem wel voor je testen lijkt mij. Woon je in de Achterhoek, stuur me dan een berichtje, Ik heb hier meer dan genoeg contacten in verschillende plaatsen die voor jou de mega willen testen.

Berichten: 2
Geregistreerd: 27 Jan 2023, 21:43

Re: Failed uploading: uploading error: exit status 1

Berichtdoor Laurens » 03 Feb 2023, 20:29

Hallo Shooter e.a.

Ik woon in Vlaardingen.... :)

Het allebei Mega's zonder CH340. Achter de USB aansluiting zit een klein zwart vierkantje ipv een rechthoekig 16 pins blokje. Ik heb plaatjes vergeleken op ww.opencircuit.nl

De Elegoo werkt wel

De ander Arduino Mega; ( "Made in Italy. ARDUINO.CC" ) werkt niet

Bijlage uploaden werkt helaas niet "Sorry, de forum bijlagequota is bereikt"

Hieronder een kopie van een andere foutmelding van een examples sketch

De bovenste van 01 Basics ; AnalogReadSerial


Is hieruit iets op te maken?


mvg
Laurens


Sketch uses 2196 bytes (0%) of program storage space. Maximum is 253952 bytes.
Global variables use 188 bytes (2%) of dynamic memory, leaving 8004 bytes for local variables. Maximum is 8192 bytes.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
Failed uploading: uploading error: exit status 1

Berichten: 62
Geregistreerd: 05 Feb 2023, 13:30

Re: Failed uploading: uploading error: exit status 1

Berichtdoor sterretjeToo » 05 Feb 2023, 14:11

Laurens schreef:Het allebei Mega's zonder CH340. Achter de USB aansluiting zit een klein zwart vierkantje ipv een rechthoekig 16 pins blokje. Ik heb plaatjes vergeleken op ww.opencircuit.nl

De Elegoo werkt wel

De ander Arduino Mega; ( "Made in Italy. ARDUINO.CC" ) werkt niet

Welk besturings systeem gebruik je?
Wordt de Arduino herkend door je besturtings system?
Heb je de loopback test geprobeerd?

1) Reset met GND verbinden op de Arduino
2) TX en RX met elkaar verbinden op de Arduino
3) Aansluiten op PC
4) Terminal programma (bv serial monitor) starten met juiste poort; baud rate maakt niet uit
5) Iets intypen, verzenden en kijken of het terugkomt

Gebruikers-avatar
Berichten: 241
Geregistreerd: 22 Jan 2013, 16:40

Re: Failed uploading: uploading error: exit status 1

Berichtdoor zuid » 05 Feb 2023, 17:04

Op het internationale arduino forum heb ik onderstaand antwoord gevonden:

"The IDE uses the stk500v2 protocol for the upload. This is for the Mega2560 and the Mega ADK but not for the Mega. The Mega uses the same upload protocol as the UNO. In the new IDE you have to select the correct processor (ATmega1280) to change to protocol for your Mega."

Wellicht helpt dit je verder. Helaas staat er niet bij welke versie is bedoeld met "new IDE"


m.v.g.
Nico


ziehttps://forum.arduino.cc/t/avrdude-stk500v2-getsync-timeout-communicating-with-programmer-again/1054081

Terug naar Arduino hardware

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 1 gast