Probleem met ESP-01 aangesloten op een I2C display 1602

Hardware geleverd door Arduino
Gebruikers-avatar
Berichten: 111
Geregistreerd: 01 Jun 2016, 20:14

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor ruudhot » 05 Dec 2021, 12:13

Heb nu ook de file geüpload naar de ESP-01, en dan vind hij/zij/het geen I2C device.

Advertisement

Gebruikers-avatar
Berichten: 111
Geregistreerd: 01 Jun 2016, 20:14

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor ruudhot » 05 Dec 2021, 12:16

Ja, nu wordt het device wel gevonden.

Code: Alles selecteren
Scanning...
I2C device found at address 0x3F  !
done

Gebruikers-avatar
Berichten: 585
Geregistreerd: 15 Nov 2015, 11:54

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor Gij Kieken » 05 Dec 2021, 12:19

Dan wordt het tijd om de scoop erbij te halen.
Meet de signalen op gpio 0 en gpio 2 (ten opzichte van massa).
Post het beeldje ,dat mag met papier en potlood en schrijf de spanning en ongeveer de tijdsbasis erbij.

Gebruikers-avatar
Berichten: 111
Geregistreerd: 01 Jun 2016, 20:14

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor ruudhot » 05 Dec 2021, 12:23

Ga ik doen Gij,

Maar dat kan even duren, zodra ik wat heb, dan post ik het.

Ik hoop dat er wat uitkomt, want na de eerste letter gaat volgens mij de ESP-01 constant resetten.
Maar dat had ik al eerder gepost.

Tot later!

Gebruikers-avatar
Berichten: 585
Geregistreerd: 15 Nov 2015, 11:54

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor Gij Kieken » 05 Dec 2021, 12:24

Dan toch gevonden op adres.
Voor de zekerheid dat het stabiel is ,wacht een beetje en laat de scanner nog een paar keer lopen.
Je zou iedere keer hetzelfde adres moeten krijgen.
Als dit lukt moet in principe de code met lcd dan ook lopen.
Maar ik zou toch kiezen voor level converters hoor.

Gebruikers-avatar
Berichten: 111
Geregistreerd: 01 Jun 2016, 20:14

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor ruudhot » 05 Dec 2021, 12:49

Ging sneller dan gedacht (als ik het goed gedaan heb tenminste).
Dit is op GPIO 0
Bijlagen
P1020313 (Aangepast).JPG
P1020313 (Aangepast).JPG (86.83 KiB) 205 keer bekeken

Gebruikers-avatar
Berichten: 111
Geregistreerd: 01 Jun 2016, 20:14

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor ruudhot » 05 Dec 2021, 12:59

En de scanner vind continu 0x3F

Gebruikers-avatar
Berichten: 585
Geregistreerd: 15 Nov 2015, 11:54

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor Gij Kieken » 05 Dec 2021, 13:18

Ziet er goed uit ,heb je een soortgelijk beeld op beide lijnen?
Als het niet lukt met de lcd code, level converting toepassen.
Er bestaan pcbtjes daarvoor,als je dat niet hebt kun je deze zelf maken met een paar Fet"s.
Andere optie is kijken of de lcd op 3.3volt werkt,dan moet je wel de contrast instelling bijstellen.
Een bijkomende test zou zijn door de code van de lcd te laden en terug de beelden te bekijken.
Met de scanner code worden geen echte data pakketten verstuurd.

Gebruikers-avatar
Berichten: 227
Geregistreerd: 22 Jan 2013, 16:40

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor zuid » 05 Dec 2021, 14:09

Gij Kieken schreef:In het geval het nog steeds werkt en met het display aangesloten ,even deze sketch uploaden
Als je een acknowledge krijgt zal je het zien in de monitor.

Code: Alles selecteren
#include <Wire.h> //include Wire.h library

void setup() {
  byte error;
  Wire.begin(); // Wire communication begin
  Serial.begin(115200);
  Wire.beginTransmission(63);
  error = Wire.endTransmission();
  if (error == 0) {
    Serial.println("I2C device acknowledge at 0x3F ");
  } else if (error == 4){
    Serial.println("Er is iets mislopen ");
  }
}

void loop() {}



LET OP Serial.begin(115200), dit kan "garbage op de serial monitor." verklaren :)

Gebruikers-avatar
Berichten: 585
Geregistreerd: 15 Nov 2015, 11:54

Re: Probleem met ESP-01 aangesloten op een I2C display 1602

Berichtdoor Gij Kieken » 05 Dec 2021, 14:17

@zuid, zou kunnen.
Ik had voor die snelheid gekozen omdat zijn serial monitor reeds daarop ingesteld was.
Alle meldingen van de upload enz kwamen blijkbaar goed door.
Vandaar om voor geen verwarring te zorgen bleef ik toen bij die baud rate.

VorigeVolgende

Terug naar Arduino hardware

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 2 gasten