Arduino Nano Schema/programmer is not responding

De regels van arduinoforum.nl
Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 19 Aug 2021, 16:22

Ik heb, na eerst problemen met solderen, nu een nieuwe Arduino nano, voorgesoldeerd met headers gekocht en daaraan de draadjes met stekkers ingestoken.
Na een keertje, deed hij het niet meer. Wel was hij ook even aan het 'jutteren' als ik aan het aarde draadje van de output rommelde (wel/geen contact). Maar toen stopte hij ermee.
Heb geprobeerd om het programmaatje opnieuw te laden via de IDE, maar krijg nu 'programmer is not responding'. De Arduino wordt wel herkend (COM4 is aangegeven, lampje brand, board gegevens kunnen worden opgehaald). Op een ander boardje kan ik nog wel uploaden, dus er is niets mis met mijn IDE of met de connecties. Ook kan ik via deze Arduino nog gewoon een ledlampje laten branden door hem met een 5V en een GND te verbinden als de Arduino aan de USB verbonden is. Dus hij is nog niet helemaal 'dood'.

Voordat ik het probleem ga oplossen (daar zie ik al veel onderwerpen over) of een nieuwe Arduino nano ga kopen, wil ik graag weten wat de oorzaak is. Dit is het schema wat ik heb gebruikt. (Heb het voor een deel zelf uitgezocht). Mogelijk ligt daar het probleem. Of mogelijk was het het 'gerommel' met de GND van de output. Mogelijk ligt het gewoon aan het boardje.

Zou iemand zo vriendelijk willen zijn om na te kijken of ik iets verkeerds in mijn schema heb gedaan?

Useless box schema.jpg
Schema
Useless box schema.jpg (37.11 KiB) 10073 keer bekeken

Advertisement

Berichten: 187
Geregistreerd: 26 Aug 2015, 11:57

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor Frits1956 » 20 Aug 2021, 12:35

De afbeelding is mij wat te klein om te zien en te onscherp bij vergroten. Wellicht dat iemand anders er wat mee kan

Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 20 Aug 2021, 14:35

Ik probeer een ander schema te fabriceren. Maar moet even uitvinden hoe (en dat ik het ook nog kan uploaden)
Bedankt voor je reactie

Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 20 Aug 2021, 16:51

Ik kan geen groter plaatje plaatsen. Mogelijk werkt deze koppeling

Schakelaar 1en 2 (S1 en S2) is een double pole schakelaar: beide schakelaars worden dus met 1 hendeltje bediend.
Schakelaar 3 is een hefboomschakelaar (roller switch). Pas als beide schakelaars 'uit' staan, dan loopt er geen stroom


https://1drv.ms/u/s!AvJEwoW966dywghtm2R ... _?e=pbvWvs

Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 20 Aug 2021, 17:04

Hier een link naar het vorige plaatje (wat meer op de werkelijkheid lijkt)

https://1drv.ms/u/s!AvJEwoW966dywgnl9UG ... l?e=iv5hC7

Berichten: 4085
Geregistreerd: 16 Okt 2013, 14:31
Woonplaats: s hertogenbosch

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor shooter » 20 Aug 2021, 19:08

oke het schema klopt niet helemaal want daar staat den de batterij verkeerd en de led ook.
het schetsje is wat dat betreft wel beter, maar de + van de led moet aan de 5Volt hangen en niet aan Vin want dat is 9 volt en dus teveel voor de arduino.
en het zal wel goed gaan, echter de 5Volt kan niet al te veel aan hoor dus 1 servo gaat goed 2 gaat ook nog wel maar dat wordt al krap.
Je zult wel merken dat die servos raar opstarten want die krijgen geen tijdpuls op tijd. net als bij stoppen dat doe je door de voeding te stoppen echter de puls gaat nog even door dus ook weet je niet waar het stopt.
Heb je ondertussen de nano wel aan de gang?
paul deelen
shooter@home.nl

Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 20 Aug 2021, 19:42

Alweer bedankt voor je werk voor mij.

Het schema is niet zo mooi getekend. Ben er nog niet handig in. Heb – op jouw advies – Fritzing geïnstalleerd en ben er dus nog maar net mee begonnen. Maar de led staat wel op de 5V en verder aan een GND. In het schetsje kun je zien dat ik voor alle output de GND aan de andere kant gebruik, al begrijp ik dat dat niet zoveel uitmaakt. De A0, waar de led aan hangt, is in de programmatuur gedefinieerd als een output pin. Had ik er natuurlijk bij moeten zeggen. Sorry.
Ik gebruik een 9V batterij omdat er 2 servo’s aan hangen. Maar die gaan natuurlijk wel via de Arduino en de 5V pin naar de servo’s.

Het stoppen is geregeld via de rolschakelaar. Als de een routine helemaal is afgerond, dan drukt deze de rolschakelaar in en daarmee stopt alles dan op een logisch moment (als het goed is). Maar met het testen doe ik het natuurlijk met de hand, omdat alles nog niet is ingebouwd. En dan heb ik inderdaad geen idee waar ik hem stop.
Ik heb nog geen nano aan de gang, maar de leverancier zou me een nieuwe sturen onder de garantie. Ik ben er daarbij maar vanuit gegaan dat het aan die Arduino lag. Hij zal morgen geleverd worden, denk ik. Dan ben ik nogal huiverig om alles weer aan te sluiten. Ben inderdaad bang dat hij weer ergens gaat hangen en ik de Arduino niet meer kan uploaden.
Heb jij een idee of het aan de Arduino lag of aan mijn schema? Of aan het feit dat ik met de hand op het juiste moment de schakelaartjes om moet zetten?

Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 20 Aug 2021, 20:14

maar, jouw antwoord indachtig, ga ik wel opletten bij het uittesten. Dus niet ergens tussendoor de stroom onderbreken met die rolschakelaar. Ik kan helaas niet alles eerst inbouwen, omdat ik een arm van een servo nog moet afstellen (via de software). Bij de eerste test stond hij een beetje laag en ging mijn moeilijk uitgezaagde armpje in een klap doormidden. Dus ik moet starten met hem wat hoger in te stellen en dan zelf, met de hand, het schakelaartje om te zetten.

Berichten: 4085
Geregistreerd: 16 Okt 2013, 14:31
Woonplaats: s hertogenbosch

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor shooter » 21 Aug 2021, 10:59

met de schakelaars stop je gewoon alles, dus ook de arduino, (dat is beter voor de batterij. en die led komt met de voeding van 9 Volt batterij af, en dat gaat niet want de arduino kan maar 5 Volt hebben, dus die moet op de 5V aansluiting van de arduino komen. en de batterij via de schakelaars op Vin.
paul deelen
shooter@home.nl

Berichten: 21
Geregistreerd: 13 Aug 2021, 16:13

Re: Arduino Nano Schema/programmer is not responding

Berichtdoor YvanderWal » 21 Aug 2021, 19:17

In het schema staat het niet goed. De led komt van de GND van de Arduino. Dus dat was een foutje in het schema.

Ik heb inmiddels de nieuwe Arduino. Hij doet het en ik heb alles ingebouwd. So far, so good, maar ik ben niet heel erg onder de indruk. Ik heb storingen door de 2 servo's. De condensator zou dat moeten oplossen, maar blijkbaar doet hij dat niet. Daarnaast vind ik al die connecties nogal gammel. De meeste heb ik maar met ducket tape aan elkaar geplakt. Dus niet erg solide.

Ik beschouw het project maar als afgerond. Ga op de makers-fair maar eens kijken hoe anderen een meer solide apparaat kunnen maken.

Yola

Volgende

Terug naar Forum regels

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 1 gast