Arduino ide "hangt" meerder minuten bij saven

IDE gerelateerde berichten
Berichten: 3
Geregistreerd: 11 Feb 2017, 19:18

Arduino ide "hangt" meerder minuten bij saven

Berichtdoor wouter49 » 03 Jul 2018, 14:21

Hallo allemaal,

Werk al enige tijd als hobby onder winxp en macOS met de arduino ide waarbij tot nu toe alle problemen wel konden worden opgelost mbv de op internet aanwezige informatie.
Na aanschaf van een nieuwe computer met windows 10 heb ik het volgende probleem met de arduino ide 1.8.5.
Als ik het programma start verschijnt vrijwel gelijk het window, laad de packages en meld ..starten.
Daarna mag ik enkele minuten wachten totdat het programma is ingeladen.
Als ik dan de sketch ga uploaden wordt wederom enige minuten van mijn tijd gevraagd.
Door het uitschakelen van het saven voor de upload was dit verholpen,maar als ik via het menu de sketch wilde saven mocht ik weer enkel minuten wachten.
Tijdens dit wachten reageert de ide totaal niet
Gedacht werd aan een probleem het lezen en schrijven van de schijf, maar helaas was het probleem er ook met een andere schijf.
Ik heb arduino geheel verwijderd en opnieuw geinstalleerd maar geen verandering kunnen krijgen.
De nieuwe computer loopt met andere programmas perfect, dus denk ik dat het probleem in de installatie van arduino 1.8.5 ligt.

Wie kan mij adviseren wat ik kan uitproberen, of heeft een oplossing

alvast dank

wouter

Advertisement

Gebruikers-avatar
Berichten: 1794
Geregistreerd: 06 Aug 2016, 01:03

Re: Arduino ide "hangt" meerder minuten bij saven

Berichtdoor Koepel » 03 Jul 2018, 14:36

Heb je wel eens een netwerkschijf gebruikt ? Bijvoorbeeld bij het installeren van de Arduino IDE of om een keer een sketch weg te schrijven ? Heb je Java geïnstalleerd ? Gaat het ook verkeerd als je voor de Arduino Uno iets compileert ? Heb je de Arduino IDE hier vandaan: https://www.arduino.cc/en/Main/Software ? Heb je iets gedownload voor speciale extra boards ? Heb je met Bibliotheek Behaar extra nieuwe libraries binnengehaald ? Zag je iets voorbij komen van de Adafruit Circuit Playground ?

Het schijnt dat er een pad naar een netwerkschijf in preferences.txt kan blijven hangen, en de Arduino IDE blijft dan wachten totdat er een timout komt.
Bij Bestand / Voorkeuren staat onderaan het bestand "preferences.txt" met het pad. Je kunt er op klikken om naar die map te gaan.

Java heb je niet nodig, de Arduino IDE heeft zijn eigen mini-Java. Wanneer je Java hebt geïnstalleerd, dan kan dat de Arduino IDE flink in de weg zitten.

Als dit allemaal niet helpt, dan is het misschien goed om toch nog eens alles te verwijderen en de Arduino IDE opnieuw te installeren. Maar dan ook echt alles verwijderen, dus ook de verborgen "arduino15" map(pen).

Iemand op dit forum had problemen, en toen heb ik de Adafruit Circuit Playground binnengehaald om te kijken wat er gebeurde. De boel liep meteen vast. Na alles verwijderen en weer opnieuw installeren werkte het weer.

Berichten: 30
Geregistreerd: 21 Apr 2013, 22:48
Woonplaats: Hoorn

Re: Arduino ide "hangt" meerder minuten bij saven

Berichtdoor babbelkwebbel » 03 Jul 2018, 22:54

Hallo,

Herken het probleem heb het ook eens gehad maar op 1 computer, de rest werkte goed, wat het veroorzaakt weet ik niet, maar ik heb toen Windows 10 er op nieuw opgezet en als eerste de Arduino software er op gezet, en vervolgens de overige programma's die ik gebruik en probleem was toen weg.
Of te wel de eerste keer stond er al van alles op de computer geïnstalleerd en werkte de Arduino software zoals je beschreef, duurde minuten lang voor er gecompileerd dan wel ge upload was, na alles opnieuw schoon opgebouwd te hebben was probleem weg, maar oorzaak geen idee, vermoedelijk een software conflict?.

Groet
Erik.

Berichten: 3
Geregistreerd: 11 Feb 2017, 19:18

Re: Arduino ide "hangt" meerder minuten bij saven

Berichtdoor wouter49 » 05 Jul 2018, 19:09

Wat heerlijk om nuttige reakties te krijgen.
Inderdaad heb ik gebruik gemaakt van een netwerkschijf, ik ga kijken of ik door verandering van de preferences.txt iets kan oplossen.
Jullie horen nog van mij.

Alvast bedankt voor de tips,

wouter

Berichten: 3
Geregistreerd: 11 Feb 2017, 19:18

Re: Arduino ide "hangt" meerder minuten bij saven

Berichtdoor wouter49 » 05 Jul 2018, 22:00

Hallo beste helpers,


Heb maar hele arduino ide weggehaald en opnieuw geinstalleerd.
Werkt weer als een speer.
Ik vermoed dat het probleem veroorzaakt werd door het eenmalig gebruik van een netwerkschijf.
Bij het veranderen van het schrijven naar de lokale disk is waarschijnlijk de preferences.txt niet goed bijgewerkt.

Veel dank voor de hulp,

groet

wouter

Terug naar Arduino IDE

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 0 gasten