Arduino DUE relay doet vreemd

Projecten die niet passen in bovenstaande onderwerpen
Gebruikers-avatar
Berichten: 32
Geregistreerd: 18 Sep 2015, 12:31

Arduino DUE relay doet vreemd

Berichtdoor SpeedFM » 03 Nov 2017, 21:48

Hallo,

Ik heb een Arduino DUE board en een 1 kenaal relay.
Ik heb de relay aangesloten op mijn Arduino DUE, alleen gebeurd er iets vreemds als ik hem aan doe.
Staat de relay uitgeschakeld, hoor ik een brommetje uit de relay komen en brand de groene ledje zachtjes.
Als ik hem inschakel, is er niks aan de hand.
Achter op de relay staat low level trigger, betekend dit dat de digital PWM een high level trigger is?
Ik heb hem op 43 als op 45 geprobeerd, en heb de stroom ook gemeten, daar is niks geks aan.
Mocht er een oplossing zijn, ben ik daar zeer blij mee.
Alvast bedankt voor alle hulp.

Mvg,
Marco
Beginner Arduino DUE.

Advertisement

Gebruikers-avatar
Berichten: 4658
Geregistreerd: 13 Mei 2013, 20:57
Woonplaats: Heemskerk

Re: Arduino DUE relay doet vreemd

Berichtdoor nicoverduin » 03 Nov 2017, 22:22

Is het een 5v relay?
En low-level trigger betekent dat een low hem aanzet. Dus zo snel mogeijk pinmode output en een High er naartoe schrijven
Docent Software Engineering, Embedded ontwikkelaar & elektronicus
http://www.verelec.nl

Gebruikers-avatar
Berichten: 32
Geregistreerd: 18 Sep 2015, 12:31

Re: Arduino DUE relay doet vreemd

Berichtdoor SpeedFM » 03 Nov 2017, 22:29

Ik heb een 5v relay, word aangestuurd met pinout.
Hoe bedoelt u precies met zo snel mogelijk?
Beginner Arduino DUE.

Gebruikers-avatar
Berichten: 4658
Geregistreerd: 13 Mei 2013, 20:57
Woonplaats: Heemskerk

Re: Arduino DUE relay doet vreemd

Berichtdoor nicoverduin » 03 Nov 2017, 23:40

Ja maar waar komt de 5v vandaan?
Docent Software Engineering, Embedded ontwikkelaar & elektronicus
http://www.verelec.nl

Gebruikers-avatar
Berichten: 32
Geregistreerd: 18 Sep 2015, 12:31

Re: Arduino DUE relay doet vreemd

Berichtdoor SpeedFM » 04 Nov 2017, 10:01

Ik heb de 5v en de GND van de Arduino board gehaald.
Kleine toevoeging: Als ik de relai niet in de schets heb, dan is de relay plus het ledje uit.

Als ik de onderstaande schets gebruik, is LOW on en HIGH off.
digitalWrite(Relay, LOW); <-- Relay off
digitalWrite(Relay, HIGH); <-- Relay on
Normaal is dat andersom, toch blijkt dit goed te werken.
Nu bromt de relay niet meer als die off moet.
Beginner Arduino DUE.

Berichten: 2286
Geregistreerd: 16 Okt 2013, 14:31
Woonplaats: s hertogenbosch

Re: Arduino DUE relay doet vreemd

Berichtdoor shooter » 04 Nov 2017, 10:33

Het relais trekt teveel stroom uit de DUE, zorg voor een aparte voeding (van 5 Volt) en sluit daar je relais op aan.
paul deelen
shooter@home.nl

Gebruikers-avatar
Berichten: 32
Geregistreerd: 18 Sep 2015, 12:31

Re: Arduino DUE relay doet vreemd

Berichtdoor SpeedFM » 04 Nov 2017, 13:05

Beetje raar, omdat ik ook nog een dubbele relays gebruik, die normaal werken.
Dan moet zoon enkel relay niet veel stroom gebruiken.
Ook heb ik dit uitgemeten, de uitgang zit wat bij de 5v.
Ik heb een adapter van 12v 2000mA aangesloten, dat zal wel voldoende moeten zijn.
Beginner Arduino DUE.

Gebruikers-avatar
Berichten: 4658
Geregistreerd: 13 Mei 2013, 20:57
Woonplaats: Heemskerk

Re: Arduino DUE relay doet vreemd

Berichtdoor nicoverduin » 04 Nov 2017, 17:17

SpeedFM schreef:Ik heb de 5v en de GND van de Arduino board gehaald.
Kleine toevoeging: Als ik de relai niet in de schets heb, dan is de relay plus het ledje uit.

Als ik de onderstaande schets gebruik, is LOW on en HIGH off.
digitalWrite(Relay, LOW); <-- Relay off
digitalWrite(Relay, HIGH); <-- Relay on
Normaal is dat andersom, toch blijkt dit goed te werken.
Nu bromt de relay niet meer als die off moet.

Modernere relais kunnen gejumpered worden of ze op HIGH of LOW reageren.
Voor wat betreft de voeding:
Het is heel fijn dat je een adapter van 2A (van mij part 100A) hebt. Op het bordje zit een regulator die de stroom begrenst (500mA). Nu zal het met een of 2 relais wel werken maar op enig moment is het over.
Docent Software Engineering, Embedded ontwikkelaar & elektronicus
http://www.verelec.nl

Gebruikers-avatar
Berichten: 32
Geregistreerd: 18 Sep 2015, 12:31

Re: Arduino DUE relay doet vreemd

Berichtdoor SpeedFM » 04 Nov 2017, 17:29

nicoverduin schreef:
SpeedFM schreef:Ik heb de 5v en de GND van de Arduino board gehaald.
Kleine toevoeging: Als ik de relai niet in de schets heb, dan is de relay plus het ledje uit.

Als ik de onderstaande schets gebruik, is LOW on en HIGH off.
digitalWrite(Relay, LOW); <-- Relay off
digitalWrite(Relay, HIGH); <-- Relay on
Normaal is dat andersom, toch blijkt dit goed te werken.
Nu bromt de relay niet meer als die off moet.

Modernere relais kunnen gejumpered worden of ze op HIGH of LOW reageren.
Voor wat betreft de voeding:
Het is heel fijn dat je een adapter van 2A (van mij part 100A) hebt. Op het bordje zit een regulator die de stroom begrenst (500mA). Nu zal het met een of 2 relais wel werken maar op enig moment is het over.

Hartelijk dank voor de informatie.
Dus, als ik hem met mijn code hem op HIGH zet, moet hij uit zijn en LOW aan.
De relay schakelt dan succesvol aan en uit.
Ik heb op mijn Arduino wat meer relays aangesloten, merk niet dat hij daar last van heeft.
Ook vertraagd het met internet shield ook niet, ik denk dat het wel mee valt.
Wel een goede tip over de adapter, zover was ik nog niet.
Beginner Arduino DUE.

Terug naar Overige projecten

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 6 gasten