ESPDuino reageert niet

IDE gerelateerde berichten
Berichten: 1
Geregistreerd: 23 Nov 2017, 00:47

ESPDuino reageert niet

Berichtdoor PT_ » 23 Nov 2017, 00:53

Hey iedereen,

ik heb laatst een ESPDuino gekocht (een goedkope Chinese versie van http://gearbest.com ), maar toen ik hem wilde verbinden naar m'n laptop kreeg ik telkens de melding
Code: Alles selecteren
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

jssc.SerialPortException: Port name - COM6; Method name - closePort(); Exception type - Port not opened.
   at jssc.SerialPort.checkPortOpened(SerialPort.java:878)
   at jssc.SerialPort.closePort(SerialPort.java:1088)
   at cc.arduino.plugins.wifi101.flashers.java.FlasherSerialClient.close(FlasherSerialClient.java:98)
   at cc.arduino.plugins.wifi101.flashers.java.JavaFlasher.testConnection(JavaFlasher.java:56)
   at cc.arduino.plugins.wifi101.UpdaterImpl$2.run(UpdaterImpl.java:110)
processing.app.SerialException: Fout bij het openen van seriële poort "COM6"
   at cc.arduino.plugins.wifi101.flashers.java.FlasherSerialClient.open(FlasherSerialClient.java:86)
   at cc.arduino.plugins.wifi101.flashers.java.JavaFlasher.testConnection(JavaFlasher.java:50)
   at cc.arduino.plugins.wifi101.UpdaterImpl$2.run(UpdaterImpl.java:110)
Caused by: jssc.SerialPortException: Port name - COM6; Method name - openPort(); Exception type - Port not found.
   at jssc.SerialPort.openPort(SerialPort.java:167)
   at cc.arduino.plugins.wifi101.flashers.java.FlasherSerialClient.open(FlasherSerialClient.java:54)
   ... 2 more
java.lang.Exception: Programmer not responding
   at cc.arduino.plugins.wifi101.flashers.java.FlasherSerialClient.hello(FlasherSerialClient.java:105)
   at cc.arduino.plugins.wifi101.flashers.java.JavaFlasher.testConnection(JavaFlasher.java:51)
   at cc.arduino.plugins.wifi101.UpdaterImpl$2.run(UpdaterImpl.java:110)

Toen ging ik naar de Firmware Updater, de goede poort geselecteerd, en toen kreeg ik de melding "Programmer not responding". Na wat rondzoeken op het internet las ik een aantal malen dat ik de ch340 driver moest installeren ofzo, en dat heb ik ook gedaan van deze website. Dat bleek ook niet te werken, want nadat ik dat geinstalleerd had, deed hij het nog steeds niet. Meer ideeen wat ik kan doen om het wel te laten werken? Alvast bedankt! :)

EDIT: sorry, lijkt erop dat dit de verkeerde subforum is.

Advertisement

Gebruikers-avatar
Berichten: 1790
Geregistreerd: 06 Aug 2016, 01:03

Re: ESPDuino reageert niet

Berichtdoor Koepel » 24 Nov 2017, 02:43

Helaas weet ik er te weinig van af.
Er zijn echter twee dingen die me opvallen.
COM6 lijkt niet te bestaan. Hoe heb je de juiste COM poort gekozen? De bedoeling is dat je die via het menu zelf kiest.
Om zomaar iets willekeurigs van een onbekende plek van internet te downloaden lijkt me niet veilig. Je kunt die driver misschien verwijderen, en dan de driver installeren die de fabrikant zelf op zijn eigen website heeft gezet: http://www.wch.cn/download/CH341SER_EXE.html
Ik weet niet hoe betrouwbaar dat boardje is. Zit er misschien gammele firmware op?
Bij WeMos wordt je doorgestuurd naar AliExpress waar je met iDeal kunt betalen: https://wiki.wemos.cc/products:d1:d1_mini

Terug naar Arduino IDE

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 2 gasten