bibliotheek/compimler probleem

IDE gerelateerde berichten
Berichten: 1
Geregistreerd: 14 Jul 2017, 10:58
Woonplaats: voorburg

bibliotheek/compimler probleem

Berichtdoor Andrew007 » 14 Jul 2017, 11:14

ik ben nieuw in de wereld van Arduino normaal programeer ik
een beetje PHP HTML CSS
dit leek me zeer leuk om dat het programmeren
Heb zelf 4x er en er af de ide van Arduino (van de site ) maar niks
zo als ik het kan begrijp kan hij kan de compiler cq bliotheek niet vinden
nu vermoed ik dat er iets met me bootloader is kan dat ?

systeem win7…..32 bits
Foutmelding:
Arduino: 1.8.3 (Windows 7), Board:"Arduino/Genuino Uno"
exec: "C:\\Users\\Andrew\\AppData\\Local\\Arduino15\\packages\\arduino\\tools\\avr-gcc\\4.9.2-atmel3.5.4-arduino2/bin/avr-g++": file does not exist
Fout bij het compileren van board Arduino/Genuino Uno
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\EEPROM: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\EEPROM
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\HID: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\HID
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SoftwareSerial: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SoftwareSerial
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SPI: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SPI
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\Wire: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\Wire
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\EEPROM: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\EEPROM
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\HID: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\HID
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SoftwareSerial: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SoftwareSerial
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SPI: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\SPI
Ongeldige bibliotheek gevonden in C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\Wire: C:\Users\Andrew\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.19\libraries\Wire
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
ik hoop dat iemand mij kan helpen
bij voorbaat bedankt

Advertisement

Gebruikers-avatar
Berichten: 4408
Geregistreerd: 13 Mei 2013, 20:57
Woonplaats: Heemskerk

Re: bibliotheek/compimler probleem

Berichtdoor nicoverduin » 14 Jul 2017, 12:12

De bootloader kan niet heh.... die zit op de chip... en zover kom je niet
Embedded ontwikkelaar & elektronicus
http://www.verelec.nl

Gebruikers-avatar
Berichten: 1185
Geregistreerd: 06 Aug 2016, 01:03

Re: bibliotheek/compimler probleem

Berichtdoor Koepel » 15 Jul 2017, 14:08

Het lijkt alsof je installatie van Arduino verkeerd is gegaan, of dat er oude en nieuwe Arduino dingen door elkaar lopen.
Misschien kun je een uninstall van de Arduino IDE doen.
Dan de map C:\Program Files\Arduino deleten.
Dan alle verborgen "arduino15" mappen verwijderen. Dit is het belangrijkste deel, dus niet overslaan.
Eventueel nog de ongebruikte libraries in je custom "libraries" map nog verwijderen. Dat staat naast je projecten in "Mijn documenten\Arduino\libraries".
Daarna de Arduino IDE opnieuw installeren.

Gebruikers-avatar
Berichten: 1185
Geregistreerd: 06 Aug 2016, 01:03

Re: bibliotheek/compimler probleem

Berichtdoor Koepel » 17 Jul 2017, 23:15

Je kunt eens een andere computer proberen.

Krijg je dezelfde foutmeldingen ? Dat is volgens mij niet mogelijk als je de "arduino15" map(pen) hebt verwijderd.

Terug naar Arduino IDE

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 1 gast